eNSP实验

news/2024/2/29 2:27:06

前言

本文记录了使用eNSP进行组网,学习、巩固一些之前学的网络基础知识和协议。

一:同网段、网关互通

网络拓扑如下:

AR1的配置:
interface G0/0/0
ip address 192.168.10.1 24

PC1和PC2的配置(IP地址和网关设置)

最终实现PC1、PC2、网关之间相互ping通

 二:以太网VLAN实验

PC1、PC3(vlan3000),PC2、PC4(vlan3200)。交换机和PC直接相连的口设置成access,交换机之间相连的口设置成trunk。最终实现PC1和PC3之间通信,PC2、PC4之间通信。

网络拓扑如下:

交换机配置如下
批量创建vlan:vlan batch 3000 3200修改端口类型access:
int GigabitEthernet 0/0/1
port link-type access
port default vlan 3000int GigabitEthernet 0/0/2
port link-type access
port default vlan 3200修改端口类型trunk:(注意,s3700只有两个千兆口,用完之后只能有Eth来进入端口进行配置)
int Eth0/0/3
port link-type trunk
port trunk allow-pass vlan all

使用display current-configuration来查看当前交换机的配置情况

给PC设置拓扑中对应的IP

最终实现相同vlan下的PC之间可以ping通,不同vlan之间的PC不能相互ping通。

三:静态路由

使用交换机为了实现不同网段之间的通信,可以设置静态路由,指明要到达的网络和到达该网络的下一跳IP地址(next hop)。在交换机中,静态路由通常用于配置简单的网络,其中网络拓扑相对稳定,不经常发生变化。

网络拓扑如下:

1、路由器给端口配置IP(AR3)
int GigabitEthernet 0/0/0
ip address 192.168.1.254 255.255.255.0interface GigabitEthernet0/0/1
ip address 192.168.2.1 255.255.255.02、路由器给端口配置IP(AR4)
interface GigabitEthernet0/0/0
ip address 192.168.3.254 255.255.255.0interface GigabitEthernet0/0/1
ip address 192.168.2.2 255.255.255.03、路由器设置静态路由的方式
针对右边那个路由器(AR4)
ip route-static 192.168.1.0 24 192.168.2.1
针对左边那个路由器(AR3)
ip route-static 192.168.3.0 24 192.168.2.2
为了实现pc1(1网段)和pc2(3网段)可以通信,要给两个路由器分别配一条静态路由
主要是要到达的网络和下一条的ip地址

使用display ip routing-table命令来查看路由器的路由表信息

左侧路由器AR3的route-table

右侧路由器(AR4)的route-table 

PC1和PC2的设置

PC1 ping PC3可以正常ping通

选择一个路由器端口进行抓包查看

四: OSPF动态路由

基本协议分析

  1. 链路发现:OSPF路由器通过发送Hello消息来发现相邻的OSPF路由器,建立邻居关系。

  2. 建立邻居关系:一旦两个OSPF路由器之间建立了邻居关系,它们将开始交换链路状态信息。

  3. 构建链路状态数据库(LSDB):每个OSPF路由器将收集到的链路状态信息存储在本地的LSDB中,以反映整个网络的拓扑。

  4. 计算最短路径树:OSPF路由器使用Dijkstra算法基于LSDB中的信息计算出最短路径树,以确定最佳的路由。

  5. 更新路由表:根据最短路径树计算结果,每个OSPF路由器将更新其路由表,以决定如何将数据包传输到目标地址。

  6. 定期更新:OSPF路由器定期发送LSA(Link State Advertisement)来更新链路状态信息,以适应网络拓扑的变化。

  7. 故障检测与恢复:OSPF能够检测到链路或路由器的故障,并迅速调整路由表以适应故障的发生,从而保持网络的可靠性。

基本网络拓扑:

路由器OSPF添加单区域
ospf
area 0
network 192.168.1.0 0.0.0.255
network 192.168.2.0 0.0.0.255

两路由器之间OSPF hello信息交互

 

查看路由器中路由表信息,会多出一条OSPF的路由信息

左侧路由器AR3:

右侧路由器AR4:

两PC IP和网关的设置

两PC间可以相互ping通 

 

五:RIP协议

RIP协议基本流程

  1. 路由器交换路由信息

    • RIP路由器周期性地广播其路由表给相邻的路由器。
    • 路由器将自己的路由表发送到邻居,并接收邻居路由表的更新。
  2. 计算最佳路径

    • 使用距离向量算法(Distance Vector Algorithm),RIP依靠跳数(hop count)来衡量到达目的地的距离。
    • 路由器将接收到的路由信息与自己的路由表进行比较,更新路由表并选择最佳路径。
  3. 定期更新

    • 路由器定期广播自己的路由表,以确保网络中其他路由器了解到最新的路由信息。
    • 默认更新时间为30秒。

网络拓扑图如下:

路由器RIP配置过程(左侧AR1)
rip
network 192.168.1.0
network 10.0.0.0路由器RIP配置过程(右侧AR2)
rip
network 192.168.2.0
network 10.0.0.0

两路由器交换相应的路由表信息,分别知道了到达另一网段的下一跳地址(next hop)是多少

两PC IP和网关的设置

 两PC之间也可以成功ping通

总结

以上就是本文的全部内容了,希望可以帮助到你。 


https://www.xjx100.cn/news/3118948.html

相关文章

【产品设计】SaaS产品数据分析之指标与标签

数据分析能够应用到各个领域和岗位,那么在SaaS产品中的应用会是如何?本文将探索SaaS产品在数据分析中的应用,并对其指标与标签的设计进行总结分析,一起来看看吧。 数据分析是业务开展过程中,收集记录各种行为产生的数据…

高效办公:如何使用视频剪辑工具批量转码,mp4视频到TS视频

在视频处理过程中,转码是一项常见的任务。将MP4视频转换为TS视频可以提供许多优势,包括更好的兼容性、更广泛的设备和平台支持以及更高的视频质量。然而,手动转码大量视频文件可能会非常耗时且效率低下。为了实现高效办公,可以使用…

MySQL运行docker容器性能

自从使用docker以来,就经常听说MySQL数据库最好别运行在容器中,性能会损失很多。一些之前没使用过容器的同事,对数据库运行在容器中也是忌讳莫深,甚至只要数据库跑在容器中出现性能问题时,首先就把问题推到容器上。 那…

Redis 实战缓存

本篇概要: 1. 设置、查询、获取过期时间;2. 缓存穿透:设置空键;3. 封杀单ip;4. 封杀ip段;5. 缓存预热;6. 使用 hash 数据类型保存新闻的缓存,增加点击量;7. Sorted set&a…

SQL Server 2008 使用concat报错

SQL Server 2008 使用concat报错 在 SQL Server中,CONCAT 函数是从 SQL Server 2012 版本开始引入的,所以在 SQL Server 2008 中使用 CONCAT 函数会导致错误。 如果你想要连接字符串,有几种替代方法可以考虑: 使用 运算符&…

统信桌面版arm系统安装火狐浏览器和浏览器驱动

一、系统信息 二、下载浏览器和驱动 1、浏览器 https://security.debian.org/debian-security/pool/updates/main/f/firefox-esr/firefox-esr_115.5.0esr-1~deb10u1_arm64.deb 2、驱动 https://github.com/mozilla/geckodriver/releases geckodriver-v0.33.0-linux-aarch6…

docker中安装mysql,远程连接

docker中安装mysql,远程连接 安装mysql 拉取mysql镜像 搜索mysql镜像 docker search mysql建议使用Oracle官方标记的 拉取镜像 docker pull mysql# 查询镜像是否拉取成功 docker images启动mysql镜像 需要做端口映射 docker run --name mysql02 -p3306:3306 -e …

算法通关村第一关——链表经典问题之删除链表元素笔记

删除链表节点 总结一下高频常用的删除链表结点的情况,无论对链表进行何种操作,都需要精确查找和精确指向。另外,在删除链表节点时有一个很好用的技巧:虚头结点,将头结点的特殊性转化为一般,在后面具体阐述…